cPanel Releases EasyApache 3.8.2 with Support for mod_ruid2

The latest release of EasyApache includes improvements to several third-party libraries and utilities.

Updates to EasyApache 3.8.2 include support for mod_ruid2 version 0.9.4. The mod_ruid2 module is a suexec module for Apache 2.0 that provides performance similar that of mod_php with the security of suphp. This module allows PHP applications to run as the user, instead of as the user nobody in a manner similar to suphp. However, mod_ruid2 is incompatible with some EasyApache modules, such as FastCGI, mod_cache, mod_disk_cache, mod_mem_cache, and ModMono. While mod_ruid2 may be ideal for many environments, cPanel recommends testing and verification that it is appropriate for your configuration. Generally, mod_ruid2 is not considered to be production-worthy.

mod_ruid2fixed.png

EasyApache 3.8.2 also provides:

  • EasyApache operation with FastCGI
  • Updates to numerous third-party libraries and tools
  • Updates to CloudLinux APR patches (mod_hostinglimits)

The final major update to EasyApache changes the default PHP 5 version to 5.3.8 and the default PHP 4 version to 4.4.9.

We strongly recommend that all server admins rebuild their EasyApache profile immediately.

To rebuild the EasyApache profile:

  1. Log in to WHM as the root user.
  2. Click on the EasyApache (Apache Update) link in the left menu.
  3. If you wish to keep the same configuration, simply click the Build Profile Now button at the bottom of the screen.

Apache_SC_2.png

For more information regarding these updates, please visit:

Posted in: Press Releases | Tagged: