cPanel Security Advisory: Truncated Password Brute Force Vulnerability

Summary
Updated builds of cPanel 9.9.8  that fix a security issue are available for users of EDGE, CURRENT, RELEASE and STABLE.

Security Rating
This update has been rated as having a trivial security impact by the cPanel Security team.

Description
The vulnerability is caused due to passwords for webmail accounts being truncated to eight characters. This makes it possible to access a webmail account, where a password longer than eight characters has been configured, with an eight character long password matching the first eight characters of the account’s password.

Solution
cPanel users should update to 9.9.8 build 29 or higher, which contains a fix for this issue.

References
Discovered by: Andrey Bayora
http://secunia.com/advisories/12943/

Posted in: News